Citroen C4 2011, ABS/ESP felmeddelande

MekNiklas
22 maj · 2 Inlägg
#1

Har alltså en Citroen C4 från 2011 som får upp ABS/ESP felmeddelanden på instrumentpanelen.

Meddelandet dyker upp så fort bromspedalen trycks ner, oavsett om bilen rullar eller ej.

Efter felkodssökning hittade jag felkod C0040 vilket betyder:

Definition: Right Front Wheel Speed Sensor

Possible causes
– Faulty Right Front Wheel Speed Sensor
– Right Front Wheel Speed Sensor harness is open or shorted
– Right Front Wheel Speed Sensor circuit poor electrical connection
Symptoms
– Antilock Brake System (ABS) warning light ON

Försökte då mäta ABS-givare höger fram. Resistens samt växelspänning när jag snurrade hjulet men fick inga värden. Provade samma sak på den andra "friska" sidan. Inga värden där heller. Oklart hur jag skall mäta denna typ av sensor. Bilen har "inbyggd" magnetring i hjullagret.

Körde en sväng med läsaren på live data och den visade då att alla givare följde varandras värden. Förutom höger fram som ibland spikade och droppade. Så något knas med den givaren tycks det vara.

Eftersom jag inte kunde mäta mig fram till om givaren var trasig eller ej, bytte jag plats på höger och vänster sida för att utesluta felaktig givare. Nollade koderna och startade på nytt. Felkod C0040 igen, vilket får mig att tro att givaren är okej, men något mellan givarens konstakt och kabeln upp till datorn är vajsing.

Om jag mäter kontakten där givaren satt, vad skall jag ha då? 12 volt? Eller ska jag mäta något annat?

MekNiklas
22 maj · 2 Inlägg
#2

Mätte kontakterna från datorn. Båda sidor hade samma resistans. När jag mätte spänningen hade vänster sida 11,5 och höger sida 13,6. Vet dock inte hur jag ska tolka dessa värden.

jaka54
23 maj · 3 703 Inlägg
#3

Hej!
När jag hade samma fel som du (ABS/ESP lampa på instrumentet lyser) på min Audi TT så åkte jag till en bilmeck och de kollade felkoder och fick fram att det var fel på ABS givaren på höger framhjul och intermitent på vänster fram.
Skickade eftyer nya Bosch-givare på eBay och bytte själv (lite bökigt då de måste slås ut/lirkas ut) Efter bytet försvann varningen och allt fungerade .

Senast redigerat av jaka54 (23 maj )

Senast i forumet
Diskussionsforum
Projekt
Evenemang