BMW e87 116i 2005 DTC- och ABS-lampan varnar

Ivenblixt
28 november 2020 · 24 Inlägg
#1

Har en e87 som varnar för fel med ABS och ”körstabilitetsreglering” som det står i instruktionsboken.
Jag har kunnat läsa av två felkoder, 2D0F och 29DD.
Bilen funkar annars som den ska och används flitigt trots varningarna. Vet inte om ABS funkar iofs, har inte testat att tvärbromsa på grus än, borde kanske det. Under en period hade vi problem med att DTC ströp kraft från motorn till hjulen. Då kunde vi stänga av DTC och då funkade det som vanligt.

Jag har försöka kolla ABS-givarna som jag hittat är av typen 2-orolig Hallgivare. Har läst på givarspecialisten.se att de bör växla mellan 0V och 0,5-2V ungefär, men jag får inget utslag på någon utav de fyra givarna.

Nån som har erfarenhet och idéer? Just nu lutar det åt att sälja den i befintligt skick vilket känns oerhört trist.

Utmarks-Loke
28 november 2020 · 3 685 Inlägg
#2

Som sagt beror det säkert på ABS. Det vanligaste är att en sensor är sönder, eller tandhjulen den läser av. Kolla så inte rost har tryckt iväg tandhjulet så det hamnat på fel avstånd från sensorn, ibland kan det vara så illa att den till och med skaver mot sensorn. För det uppkom väl inte efter att du satte på vinterhjulen?

Det allra enklaste är förstås att koppla in en lite mer avancerad felkodsläsare och se på live data från sensorerna när bilen rullar.

husseman
28 november 2020 · 843 Inlägg
#3

Hmm..2D0F är felkod på LM , 29DD är abs relaterat, o borde gå att hitta felet i kablar eller styrdon.
mvh/husse

Ivenblixt
28 november 2020 · 24 Inlägg
#4

Utmarks-Loke skrev:
Som sagt beror det säkert på ABS. Det vanligaste är att en sensor är sönder, eller tandhjulen den läser av. Kolla så inte rost har tryckt iväg tandhjulet så det hamnat på fel avstånd från sensorn, ibland kan det vara så illa att den till och med skaver mot sensorn. För det uppkom väl inte efter att du satte på vinterhjulen?

Det allra enklaste är förstås att koppla in en lite mer avancerad felkodsläsare och se på live data från sensorerna när bilen rullar.

Jag tycker bara det är konstigt att vi inte får utslag på NÅGON av givarna.
Men en avläsning med en bättre läsare är nog bra som du skriver.

husseman skrev:
Hmm..2D0F är felkod på LM , 29DD är abs relaterat, o borde gå att hitta felet i kablar eller styrdon.
mvh/husse

LM=luftmassemätare? Kan det finnas samband mellan dessa eller är det troligt två olika fel?

husseman
28 november 2020 · 843 Inlägg
#5

Ivenblixt skrev:

Utmarks-Loke skrev:
Som sagt beror det säkert på ABS. Det vanligaste är att en sensor är sönder, eller tandhjulen den läser av. Kolla så inte rost har tryckt iväg tandhjulet så det hamnat på fel avstånd från sensorn, ibland kan det vara så illa att den till och med skaver mot sensorn. För det uppkom väl inte efter att du satte på vinterhjulen?

Det allra enklaste är förstås att koppla in en lite mer avancerad felkodsläsare och se på live data från sensorerna när bilen rullar.

Jag tycker bara det är konstigt att vi inte får utslag på NÅGON av givarna.
Men en avläsning med en bättre läsare är nog bra som du skriver.

husseman skrev:
Hmm..2D0F är felkod på LM , 29DD är abs relaterat, o borde gå att hitta felet i kablar eller styrdon.
mvh/husse

LM=luftmassemätare? Kan det finnas samband mellan dessa eller är det troligt två olika fel?

Hmm, LM är en klassisk felkod som man normalt skiter i o raderar. Folk byter dom i massa fall, fast inget e fel på dom.
Du borde koncentrera dig på abs styrdonet , kablar o givare. Ett bra obd  instrument kan ge dig all information du behöver. Lycka till..
mvh/husse

Ivenblixt
16 december 2020 · 24 Inlägg
#6

Liten uppdatering:
Chansade och bytte alla sensorer, först fram och fick ingen skillnad, sen bak och då slocknade ABS-lampan och den andra gula lampan. Antisladd eller DTC eller vad det är.
Kvar är nu handbromslampan och "upphissade bilen"-lampan som ska betyda nedslitna belägg. Dom bytte jag fram eller bak (minns inte, suck) för typ 50 mil sen så jag får väl byta den andra också.

Tack för hjälpen!

Brådhis * Voff voff *
16 december 2020 · 6 109 Inlägg
#7

Ivenblixt skrev:
Liten uppdatering:
Chansade och bytte alla sensorer, först fram och fick ingen skillnad, sen bak och då slocknade ABS-lampan och den andra gula lampan. Antisladd eller DTC eller vad det är.
Kvar är nu handbromslampan och "upphissade bilen"-lampan som ska betyda nedslitna belägg. Dom bytte jag fram eller bak (minns inte, suck) för typ 50 mil sen så jag får väl byta den andra också.

Tack för hjälpen!

Du kan ju se i färddatorn om det är fram eller bak. Du kan/ska även nollställa där efter bytet.

The evening sun touched gently on the eyes of Lucy Jordan...
Utmarks-Loke
16 december 2020 · 3 685 Inlägg
#8

Ja, man måste nollställa bromsbeläggsvarningen efter man bytt belägg innan lampan slocknar. Kolla på youtube hur man gör, det är enklast.

Senast i forumet
Diskussionsforum
Projekt