Volvo v50 -04 (Löst)

MickeEng
24 april · 318 Inlägg

Hallå!
Tänkte höra här eftersom jag inte är så insatt i bilel.
Har en v50 2.4 -04 som instrumentbelysningen över varvräknaren slockna. Så jag beställde ett nytt instrument på bildelsbasen till samma årsmodell och motor och skruvade i bilen i typ februari. Har funkat jättebra tills jag var och besiktiga bilen i slutet av mars, där kopplade dom in sin läsare och körde självtester och tog fel koder och det var helt felfritt. Så samma vecka slockna innerbelysningen och instrumentet inga kontrollampor, hastighetsmätare, varvräknare allt är slock, vad jag har kommit fram till så hänger instrumentet och inner belysningen ihop. För övrigt fungerar precis allting på bilen har gått igenom alla funktioner i bilen. Fick hjälp att  läsa ut fel koder som säger kommunikations fel. Vad är det som kan ha hänt har kollat alla säkringar, parkera bilen och när jag typ fem dar senare skulle ha den så var felet där. Har testat att låta bilen stå strömlös över natten men det hjälper inte, någon som har något tips.

Senast redigerat av MickeEng (fredag 11:20)

Brådhis * Voff voff *
25 april · 6 935 Inlägg

Provat att koppla in det gamla instrumenthuset igen?

The evening sun touched gently on the eyes of Lucy Jordan...
Volvo 480 Turbo "The only way is up" (1988)
Volvo V70 2.4d "Hemlig XI" (2007)
Mossan1
25 april · 306 Inlägg

För att kunna ge svar behövs felkoderna.
"Kommunikationsfel" är inte en felkod, det är en del av översättningen.
Vilka styrdon har kommunikationsfel, tex?
Det ena påverkar det andra i CAN system.
Jag skulle säga att instrumentet (DIM)  bara är mottagare av information som rör innerbelysning  och det är om instrumenten ska lysa eller ej.
Info från ljussensorn, som Volvo ofta har integrerad i CCM. DVS klimatpanelen.
Över innerbelysningen är styrande CAN noden UEM, tror jag.
Strax framför backspegeln.

Men, en störning som drabbar signalerna i det CAN-nätet skulle kunna slå ut vissa funktioner.

Det är inte så ofta det fungerar rakt av med annan CAN nod från annan bil, men eftersom det fungerade några månader så måste du haft turen att det gick i detta fallet. Många parametrar spelar in där.

Bilprovningen läser för övrigt bara motorstyrdonet vid besiktning och slår ner på ev miljörelaterade felkoder.
Den ser inte felkoder i kombiinstrument, eller någon av de minst 7 andra styrdonen som bilen har.

Senast redigerat av Mossan1 (25 april )

MickeEng
25 april · 318 Inlägg

Brådhis skrev:
Provat att koppla in det gamla instrumenthuset igen?

Jo glömde skriva det testade att byta tillbaka till det gamla instrumentet, det är också svart.

MickeEng
25 april · 318 Inlägg

Mossan1 skrev:
För att kunna ge svar behövs felkoderna.
"Kommunikationsfel" är inte en felkod, det är en del av översättningen.
Vilka styrdon har kommunikationsfel, tex?
Det ena påverkar det andra i CAN system.
Jag skulle säga att instrumentet (DIM)  bara är mottagare av information som rör innerbelysning  och det är om instrumenten ska lysa eller ej.
Info från ljussensorn, som Volvo ofta har integrerad i CCM. DVS klimatpanelen.
Över innerbelysningen är styrande CAN noden UEM, tror jag.
Strax framför backspegeln.

Men, en störning som drabbar signalerna i det CAN-nätet skulle kunna slå ut vissa funktioner.

Det är inte så ofta det fungerar rakt av med annan CAN nod från annan bil, men eftersom det fungerade några månader så måste du haft turen att det gick i detta fallet. Många parametrar spelar in där.

Bilprovningen läser för övrigt bara motorstyrdonet vid besiktning och slår ner på ev miljörelaterade felkoder.
Den ser inte felkoder i kombiinstrument, eller någon av de minst 7 andra styrdonen som bilen har.

Tack Mossan1 för ett bra svar även fast jag kanske inte förstod allt. Är lite inne på att bilen upptäckt att det sitter ett annat instrument i bilen typ att miltal och så inte stämmer. Ska höra med min lokala Volvoverkstad i veckan och lämna in bilen för felsökning. Bilen som sagt fungerar annars helt ok.

Mossan1
27 april · 306 Inlägg

Det upptäcks på sekunden.
Der sätts en felkod på felaktig mätarställning, men den finns bara i styrdonen. Ingen varning, och det blir inga andra symptom.

Och visst fungerade det i flera veckor utan problem?
Uppstod problemet I DIREKT SAMBAND med bytet är det säkert så att DIM (instrumentet) inte är kompatibelt med övriga CAN moduler.

Men det blir i så fall genast.

MickeEng
27 april · 318 Inlägg

Mossan1 skrev:
Det upptäcks på sekunden.
Der sätts en felkod på felaktig mätarställning, men den finns bara i styrdonen. Ingen varning, och det blir inga andra symptom.

Och visst fungerade det i flera veckor utan problem?
Uppstod problemet I DIREKT SAMBAND med bytet är det säkert så att DIM (instrumentet) inte är kompatibelt med övriga CAN moduler.

Men det blir i så fall genast.

Jo så var det instrumentet fungerade felfritt när jag satt i det i typ 2 månader. Hade den inne på Volvo idag och dom vad jag fatta gick igenom nätverket och allt fungerade. Han som fixa med bilen sa att han hade nollat batteriet och då hade allt fungerat innerbelysning och instrument när man slog på tändningen men när bilen startades så slockna den igen. han inte göra mer idag på den tiden som var avsatt. Sa dom inte vågade ladda in mjukvara i det nya instrumentet för då kan det tydligen bli andra fel. Kan det var så att jag måste köpa ett helt nytt instrument? Ska prova att montera in det gamla instrumentet som jag har kvar och se vad som händer.

MickeEng
14 maj · 318 Inlägg

Hallå!

Har fortfarande inte löst problemet med min V50 -04 2.4i. När man plockar av+polen och låter bilen vara strömlös i typ tio minuter och återansluter batteriet så verkar allt fungera som det ska låser man bilen och låser upp så tänds innerbelysningen och info panelerna i instrumentet tänds som de ska slår man på tändningen läge två så lyser alla kontrollampor och belysning som det ska. Men när man startar bilen så slocknar allt. Har plockat ut CEM rengjort alla kontakter tagit bort alla säkringar sprayat allt med kontaktspray rengjort alla jordpunkter som har med att göra CEM. Har nollat batteriet och kopplat in det då har det lyst utan att starta bilen och låtit bilen stå typ en timme då har innerbelysning och instrument blivit svart verkar som det någon sort tids tidspåverkan. Är det någon som har en susning om vad som kan vara felet som sagt annars fungerar precis allt annat på bilen.
Delar ett litet klipp på vad som händer när man startar bilen.

https://youtu.be/UdIVMIcrSSg

Mossan1
15 maj · 306 Inlägg

Du behöver få bilen läst av tex VIDA, eller annat system som läser bilens alla styrdon. Helt klart är inte något styrdon med i matchen.

Generellt kan man inte byta någon av de större CAN noderna utan att det blir konfigureringsfel.  DIM är en av dom.

Driver Information Module = kombiinstrumentet.

MickeEng
23 maj · 318 Inlägg

Mossan1 skrev:
Du behöver få bilen läst av tex VIDA, eller annat system som läser bilens alla styrdon. Helt klart är inte något styrdon med i matchen.

Generellt kan man inte byta någon av de större CAN noderna utan att det blir konfigureringsfel.  DIM är en av dom.

Driver Information Module = kombiinstrumentet.

Hallå!

Inte så säker på det DIM fungerade ju i bilen i cirka 2,5 månad, kollade med en snubbe jag vet bytte DIM pga av samma orsak som jag bytte att halva slocknade på högersidan och det är cirka ett år sedan och hans V50 har fungerat utan problem. Ska in på Volvo nu på Onsdag för vidare fel sökning.
Provade att sätta tillbaka original DIM:en nollade batteriet samma fel, körde med bilen typ en vecka fortfarande slock. Har plockat ut CEM och rengjort alla kontakter plockat ur alla säkringar och reläer jag hittat och rengjort men icke. Har också rengjort alla jord punkter som har med detta att göra. Har skrivit upp mätarställning, värden från färddatorn allt fungerar bara att den j***a panelen är svart. Den som löser detta problem är värd en skaplig belöning.

MickeEng
29 maj · 318 Inlägg

Hallå
Jaha ja en liten uppdatering med min V50 även kallad Mr White.
Har haft han inlämnad på den lokala Volvo verkstaden som nu har felsökt alla boxar och alla nätverk som finns i denna bil.
Det är tydligen ett inbyggt relä i CEM som inte orkar hålla spänningen. Vi har kommit lite framåt i felsökningen rycker man säkringen till CEM som sitter i säkringsboxen i motorrummet så funkar allt som det ska nätverket helt grönt i typ 5 till 10 min inga fel koder sedan slocknar DIM. Det är ju typiskt att det det ska vara ett inbyggt relä som är paj. Lämnar Mr White 9juni för byte av CEM och hoppas allt löser sig.

Mossan1
30 maj · 306 Inlägg

Dom reläerna är inte inbyggda utan lödda direkt på kretskortet. Något som en elektronikkunnig eller liten elfirma fixar lätt som en plätt.
Relä kanske 100kr, plus lödningen.

Volvo ska bara sälja komplett CEM för en ohemul summa pengar.

MickeEng
30 maj · 318 Inlägg

Jo det är klart att det skulle vara en lösning, jobbar på den lokala Volvo verkstaden här i stan så jag har inte betalat något för felsökning och så och får jag delarna till typ inköpspris.
Betalar gärna lite extra för att få problemet löst och backup om det skulle bli några problem.
Hoppas att det löser den 9 juni.

MickeEng
fredag 11:20 · 318 Inlägg

Hallå!
Såja nu är problemet löst med min V50 det blev att byta CEM i bilen p.g.a ett relä i den som inte orkade hålla spänningen. Så nu funkar allt som det ska igen.

Senast i forumet
Diskussionsforum
Projekt
Evenemang